DS查找—二叉树平衡因子

DS查找—二叉树平衡因子

题目描述

二叉树用数组存储,将二叉树的结点数据依次自上而下,自左至右存储到数组中,一般二叉树与完全二叉树对比,比完全二叉树缺少的结点在数组中用0来表示。

计算二叉树每个结点的平衡因子,并按后序遍历的顺序输出结点的平衡因子。

--程序要求--

若使用C++只能include一个头文件iostream;若使用C语言只能include一个头文件stdio

程序中若include多过一个头文件,不看代码,作0分处理

不允许使用第三方对象或函数实现本题的要求

输入

测试次数t

每组测试数据一行,数组元素个数n,后跟n个字符,二叉树的数组存储。

输出

对每组测试数据,按后序遍历的顺序输出树中结点的平衡因子(测试数据没有空树)

样例输入

2

6 ABC00D

24 ABCD0EF0000H00000000000I

样例输出

B 0

D 0

C 1

A -1

D 0

B 1

I 0

H 1

E 2

F 0

C 2

A -2

Solution:

import java.util.*;
public class Main{
	private static int n;
	private static int MAXN = 1000;
	public static void main(String args[]){
		Scanner scanner = new Scanner(System.in);
		// test times
		int times = scanner.nextInt();
		for (int k = 0; k <times ; k++) {
			n = scanner.nextInt();
			char[] array = new char[n+1];
			int[] bf = new int[MAXN];//平衡因子数组,存储每个结点的平衡因子
			String string = scanner.next();//由于Java无法读取单个字符,故先读取字符串,再分割
			for (int i = 0; i <n ; i++) {
				array[i] =string.charAt(i) ;
			}
			//get bf
			//get each sub node's height
			for (int i = 0; i <n ; i++) {//计算每个结点的平衡因子
				//计算公式:左子树高度 - 右子树高度
				bf[i] = get_height(array,2*i+1)-get_height(array,2*i+2);
			}
			//后序输出各非空结点的平衡因子
			orderPrint(bf,array,0);
		}

	}

	/**
	 * 求二叉树chars中,loc位置的结点的高度(从下往上计算,而非从根节点开始计算)
	 * @param chars
	 * @param loc
	 * @return
	 */
	public static int get_height(char[] chars,int loc){
		if (loc>=n || chars[loc]=='0'){
			return 0;
		}else{
			int left = get_height(chars,2*loc+1)+1;
			int right = get_height(chars,2*loc+2)+1;
			return left>right?left:right;//返回最大高度
		}
	}
	public static void orderPrint(int[] bf,char[] chars,int i){
		if (i<n){//后序输出
			orderPrint(bf,chars,2*i+1);//先遍历左子树
			orderPrint(bf,chars,2*i+2);//然后遍历右子树
			if (chars[i]!='0')//最后访问(输出)根节点
				System.out.println(chars[i]+" "+bf[i]);
		}
	}
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
平衡二叉树平衡因子是指每个节点的左子树高度减去右子树高度的值。平衡因子可以用来判断一个节点是否平衡,如果平衡因子的绝对值大于1,则该节点不平衡。 在Java中实现平衡二叉树时,可以通过计算每个节点的平衡因子来判断是否需要进行平衡操作。当插入或删除节点后,如果某个节点的平衡因子超过了1或小于-1,就需要进行相应的平衡操作,以保持树的平衡性。 以下是一个示例代码,演示了如何计算平衡二叉树平衡因子: ```java class Node { int value; Node left; Node right; public Node(int value) { this.value = value; this.left = null; this.right = null; } } class AVLTree { Node root; // 计算节点的高度 private int height(Node node) { if (node == null) { return 0; } return Math.max(height(node.left), height(node.right)) + 1; } // 计算节点的平衡因子 private int balanceFactor(Node node) { if (node == null) { return 0; } return height(node.left) - height(node.right); } // 插入节点 public void insert(int value) { root = insertNode(root, value); } private Node insertNode(Node node, int value) { if (node == null) { return new Node(value); } if (value < node.value) { node.left = insertNode(node.left, value); } else if (value > node.value) { node.right = insertNode(node.right, value); } else { // 如果节点值已存在,则不进行插入操作 return node; } // 更新节点的平衡因子 int balance = balanceFactor(node); // 左子树不平衡 if (balance > 1) { if (value < node.left.value) { // 左-左情况,进行右旋转 return rightRotate(node); } else { // 左-右情况,先左旋转再右旋转 node.left = leftRotate(node.left); return rightRotate(node); } } // 右子树不平衡 if (balance < -1) { if (value > node.right.value) { // 右-右情况,进行左旋转 return leftRotate(node); } else { // 右-左情况,先右旋转再左旋转 node.right = rightRotate(node.right); return leftRotate(node); } } return node; } // 左旋转 private Node leftRotate(Node node) { Node newRoot = node.right; node.right = newRoot.left; newRoot.left = node; return newRoot; } // 右旋转 private Node rightRotate(Node node) { Node newRoot = node.left; node.left = newRoot.right; newRoot.right = node; return newRoot; } } public class Main { public static void main(String[] args) { AVLTree tree = new AVLTree(); tree.insert(10); tree.insert(20); tree.insert(30); tree.insert(40); tree.insert(50); } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

菜饼同学

帮助别人,就是帮助自己,共勉。

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值